Установка Unity3D и инструментов в Linux

Материал из LORWiki
Перейти к навигацииПерейти к поиску

ИСТОЧНИК

В этой статье будет описана установка Unity3D в популярных дистрибутивах и небольшой обзор имеющихся инструментов.

Установка Unity3D[править]

В большинстве дистрибутивов установка проста. Вы скачиваете установщик с сайта... а ссылки на него там нет. А всё потому что он лежит здесь. Но таким образом скоро движок перестанет поставляться - месяц назад зарелизили Unity Hub и производить установку рекомендуют именно с его помощью. Ссылки на официальном сайте всё так же нет, но в разделе бета-версий есть ссылка на форум, ссылка на который есть чуть ранее по тексту.

Для некоторых дистрибутивов есть пакеты в репозиториях. Так, для Arch Linux, Manjaro и основанных на арче дистрибутивах в AUR (Arch User Repository) есть пакеты unity-editor и unity-editor-beta. Последний - для любителей бета-версий и острых ощущений. Сам не использовал и не буду.

С AUR есть одна проблема: если вы ни коим образом не настраивали свой дистрибутив, то установщик пакетов выдаст ошибку, связанную с отсутствием места на диске. А всё по той причине, что по умолчанию включена tmpfs. Отключите её, инструкция по --ссылке. Хотя если у вас достаточно ОЗУ (от 16 ГБ), то можете не беспокоиться.

Для Debian, Fedora и Ubuntu на данный момент репозиториев нет.

Для Gentoo не особо свежие версии были найдены здесь.

Установка инструментов[править]

Редактор кода[править]

Я предпочитаю Visual Studio Code. Официальные пакеты можно скачать прямо с сайта. Они подходят для deb-дистрибутивов (Ubuntu, Debian, Linux Mint и т.д.) и rpm-дистрибутивов (Fedora и основанных на ней, либо же использующих данный формат пакетов). При установке добавляет свои репозитории в список, что позволяет получать своевременные обновления без необходимости ходить на сайт.

В Arch Linux, Manjaro, и производных от Arch Linux есть пакет code в репозитории Community Для Gentoo есть эти оверлеи. Для староверов есть MonoDevelop. Продублирую репозитории сюда:

Ubuntu

14.04

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
sudo apt install apt-transport-https
echo "deb https://download.mono-project.com/repo/ubuntu vs-trusty main" | sudo tee /etc/apt/sources.list.d/mono-official-vs.list
sudo apt update

16.04

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
sudo apt install apt-transport-https
echo "deb https://download.mono-project.com/repo/ubuntu vs-xenial main" | sudo tee /etc/apt/sources.list.d/mono-official-vs.list
sudo apt update

18.04

sudo apt install apt-transport-https dirmngr
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
echo "deb https://download.mono-project.com/repo/ubuntu vs-bionic main" | sudo tee /etc/apt/sources.list.d/mono-official-vs.list
sudo apt update

Установка

sudo apt-get install monodevelop

Debian 8

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
sudo apt install apt-transport-https
echo "deb https://download.mono-project.com/repo/debian vs-jessie main" | sudo tee /etc/apt/sources.list.d/mono-official-vs.list
sudo apt update

9

sudo apt install apt-transport-https dirmngr
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
echo "deb https://download.mono-project.com/repo/debian vs-stretch main" | sudo tee /etc/apt/sources.list.d/mono-official-vs.list
sudo apt update

Установка

sudo apt-get install monodevelop

С Fedora всё проще. Достаточно выполнить следующую команду:

sudo dnf install monodevelop

Для Arch Linux, Manjaro и производных от Arch Linux есть пакет monodevelop-stable в AUR.

Для Gentoo были найдены эти оверлеи.

Для openSUSE есть пакет monodevelop.

Для Sublime Text есть репозитории на официальном сайте. Для openSUSE есть пакет sublime_text. Для Gentoo есть в [https://gpo.zugaina.org/app-editors/sublime-text этих оверлеях.

В Fedora многие редакторы можно установить с помощью Fedy (твикер для федоры, сам добавляет репозитории).

Для редактирования можно использовать любую программу, хоть Vim. Им я не пользуюсь, но оставлю три ссылки: раз два, три.

Очень важное примечание: очистите поле External Script Editor Args, или удалите кавычки. Последнее предпочтительнее, т.к. при очистке во время открытия настроек это поле сбрасывается.

Работа с 3D[править]

Вот небольшой список пакетов для работы с 3D:

  • Blender
    • Есть в репозиториях всех (вроде бы) дистрибутивов, достаточно установить пакет blender
    • Можно загрузить с сайта архив и распаковать в любое место
  • Maya
  • Substance Painter
  • Substance Designer
  • Modo
  • 3DCoat
  • Mudbox

Некоторые из этих пакетов также есть в AUR.

Работа с 2D[править]

Небольшой список кроссплатформенных приложений для работы с 2D графикой:

  • Krita – графический редактор, основной упор делается на рисование
    • Можно загрузить с сайта, есть в репозиториях некоторых дистрибутивов (dev-games/aseprite в Gentoo, aseprite в AUR)
    • Можно загрузить в AppImage
  • Aseprite – создание анимированных спрайтов и 2D графики
    • Можно загрузить с сайта, есть в репозиториях некоторых дистрибутивов (dev-games/aseprite в Gentoo, aseprite в AUR)
    • Можно загрузить в AppImage
  • GIMP – графический редактор
    • Есть в репозиториях всех дистрибутивов
    • Можно загрузить в AppImage (немного устаревшие версии)
  • Inkskape - редактор векторной графики
    • Есть в репозиториях всех дистрибутивов
    • Можно загрузить в AppImage

Для запуска приложений в формате AppImage достаточно сделать файл исполняемым и запустить как обычное приложение.

Интеграция с Android[править]

Установка Android SDK и NDK очень простая и происходит тремя способами.

Первый - загрузка с официального сайта и распаковка архива в любое место. NDK доступен здесь.

Важное обновление: начиная с версии 2019.1.0b1 SDK и NDK можно установить через Unity Hub.

Второй - установка из репозиториев дистрибутива. Я нашёл следующие:

Третий - установка Android Studio (только SDK), которая ставится как с официального сайта, так и из репозиториев:

Android Studio требует Java (как минимум версии 8). В Ubuntu и Debian Java (версии 8) устанавливается так:

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java8-installer

В rpm-дистрибутивах надо скачать пакет с официального сайта.

Arch Linux и производные от него - список пакетов в AUR на ArchWiki. Ставить Java SE.

В Gentoo:

emerge --ask virtual/jre

Oracle Java требует принятия лицензии. Самый простой способ - добавить ACCEPT_LICENSE="*" в make.conf. Чуть сложнее - узнать лицензию и добавить её.

Скорее всего потребуется установка правил UDEV. Скопируйте этот файл в /etc/udev/rules.d/ и перезагрузите правила:

sudo udevadm control --reload-rules

Теперь просто укажите все пути в редакторе. Если вы всё сделали правильно, то станет доступна отладка на телефоне, кнопка Build and Run и все преимущества интеграции Unity3D с мобильными устройствами.

Интеграция с iPhone и iPad[править]

Увы, ничего не могу про это рассказать. Насколько я знаю, для возможности создания игр для яблочных устройств требуется одно из устройств вроде макбука.

Вместо вывода[править]

Я мог что-то забыть добавить в эту статью. Поэтому статья время от времени будет обновляться.